barrmar's place

Writings and rants about everything from gadgets to news & politics.

Windows 7 sp1

Posted by: barrmar

barrmar

The Windows 7 daily updates continue almost unabated making a quick getaway an almost impossible task. 

Following one of the more recent updates, I was informed that Windows 7 Service Pack 1 had been installed on my computer. 

This turned out to be less than good news. For a number of reasons I have hardly used the computer since but by all accounts Service Pack 1 is a really shoddy piece of work. The biggest problems seem to be with the 64 bit version, but don't imagine for a moment that the 32 bit system is at all immune. 

A whole range of problems have been sited. Installed printers are no longer there. Do what you may, and the system cannot find it. Browsers don't work properly. 

Other commonly reported problems are the refusal of USB ports to work following installation. There have also been reports of 3G modems failing to work. 

It seems that Microsoft has unleashed another Vista onto an unsuspecting public. Apparently, MS does not bother too much with testing and quality control before releasing these time-bombs onto the world. 

Finally, there is no warning that a new service pack is about to be installed. Just the usual "there are important updates ready to be installed onto your computer". It is only after the asecond or third re-boot that you see a message "Windows is configuring your computer". Well, that presentation will just have to wait! And lets hope the computer still works.

Comments (3)Add Comment
Sameer
...
written by Sameer, July 05, 2011
Interesting. I have never really been a Microsoft fan over the years, but so far I seriously havent had any complaints with windows 7 (64 bit) and everything just seems to work... first time smilies/smiley.gif Then again I havent used any older software when I got this laptop a year ago.... then again I know alot of people who share the same sentiments as you... oh and i just checked now, and to my surprise I have service pack 1 installed, noooo idea when it was installed and how long its been there....
barrmar
...
written by barrmar, July 05, 2011
As I said, I haven't had any problems yet. But I have seen a loot of complaints on the Web - many claiming that after a while the USB ports stop working! We will wait and see!
Sameer
...
written by Sameer, July 05, 2011
oops my bad, I only realised now that you said "sighted" smilies/smiley.gif
Will update you if anything fishy happens my side....

Add your 2Cents
You must be logged in to post a comment. Please register if you do not have an account yet.

busy

Member Login